If a particular page on an Internet site doesn't load for some reason or in case a link is broken, the site visitor will see an error page with a generic message. The page shall have nothing in common with the rest of the site, which may make the visitor leave your site. A solution in cases like this is a feature made available from some website hosting service providers - the option to set your own custom error pages which shall have identical style and design as your website and that can contain any images or text you want dependent upon the specific error. There are four standard errors which could take place and they involve the following so-called HTTP status codes - 400, when your web browser sends a bad request to the web server and it cannot be processed; 401, if you are supposed to log in to see some page, but you have not done this yet; 403, if you do not have a permission to see a specific page; and 404, in case a link that you've clicked leads to a file that does not exist. In all of these situations, website visitors shall be able to see your custom made content rather than a generic error page.

Custom Error Pages in Cloud Web Hosting

If you order a Linux cloud web hosting service from our company, you shall be able to set customized error pages for your websites easily and quickly, as this feature is part of all of our plans. After you have created the files and uploaded them to your website hosting account, you can go to the Hosted Domains section of your Hepsia Control Panel and click on the Edit button for the particular domain or subdomain. In the pop-up that will show up, you shall see drop-down menus for all 4 types of errors and for each one of them you can choose an Apache default page, a generic page from our system or a customized page. If you select the 3rd option, you should simply input the URL to the file you have uploaded and save the change. A different way to set personalized error pages is to create an .htaccess file in the domain or subdomain folder and to add a few lines of code in it. If you don't have prior experience or if you're just unsure how to do this, you could simply copy and paste the code from our Knowledge Base article on that topic.

Custom Error Pages in Semi-dedicated Servers

If you host your sites in a semi-dedicated server account with us, you could set custom made error pages for any of them with ease through our in-house created Hepsia hosting Control Panel. With a few clicks in the Hosted Domains section, you could change the default setting from a system page to a tailor-made one for any of the four error types. All you have to do is supply a link to each file which you have uploaded before that and then save the change. If necessary, you shall be able to revert this customization whenever you want and in exactly the same way. If you want, you can use an .htaccess file as well. It must be created/uploaded in the domain or subdomain folder belonging to the website whose error pages you intend to change and the content for this type of file can be found in our Help article on this matter.